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Including software, file formats, and audiovisual displays; may be used pursuant to applicable software licence agree-

ment; contains confidential and proprietary information of CAXperts and/or third parties which is protected by copy-

right law, trade secret law, and international treaty, and may not be provided or otherwise made available without 

proper authorization.  

Restricted Rights Legend  
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Warranties and Liabilities  
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with the terms of this licence. THE USER OF THE SOFTWARE IS EXPECTED TO MAKE THE FINAL EVALU-

ATION AS TO THE USEFULNESS OF THE SOFTWARE IN HIS OWN ENVIRONMENT.  

Trademarks 
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1 Introduction 
CopyMoveRotate is a software utility for copying, moving and rotating models and 

drawings in Intergraph PDS (rotation of drawings and moving/copying of drawings with 

composite views is not supported in this version). Copying of models is possible inside 

a single project as well as between two projects. Lines and equipment may be copied 

between projects and deleted. Additionally, design schemas (Line IDs, Unit Code, etc.), 

equipment and raceway attributes can be edited using Microsoft Excel. CopyMoveRo-

tate also provides functionality for changing Site IDs (and/or model index numbers or 

partition numbers, names and descriptions) of models and drawings. Names and de-

scriptions can also be edited for areas. CopyMoveRotate may also be controlled via 

command line parameters. 

1.1 General conventions 
This document contains many visual cues to help you understand the meaning of certain 

words or phrases. The use of different fonts for different types of information allows 

you to scan the document for key concepts or commands. Symbols help abbreviate and 

identify commonly used words, phrases, or groups of related information 

Typefaces 
Italic Indicates a system response, which is an explanation of what 

the software is doing. For example,  

 

The text is placed in the viewing plane. 

 

Bold Indicates a command name, parameter name, or dialog box 

title. Command paths are shown using an arrow between 

command names. For example, 

 

Choose File → Open to load a new file. 

 

Sans serif Indicates a system prompt or message, which requires an ac-

tion be taken by the user. For example,  

 

Select first segment of alignment 
 

Normal typewriter 

 
Indicates an actual file or directory name. For example,  

 

The ASCII report is stored in the layout.rpt file. 

 
Bold typewriter 

 
Indicates what you literally type in. For example,  

 

Key in original.dat to load the ASCII file. 
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Symbols 
This document uses the following symbols to identify special information: 

 Note – important supplemental information. 

 Map or path – shows you how to get to a specific command or form. 

 More information – indicates there is additional or related information. 
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2 Installation 

2.1 Setup 
Requirements: 

▪ Supported operating systems: 

▪ Microsoft Windows XP 

▪ Microsoft Windows Server 2003 

▪ Microsoft Windows Vista 

▪ Microsoft Windows 7 

▪ PDS 6.4 or later 

▪ MicroStation SE/J 

▪ Microsoft Excel 2000 or later 

Administrator rights are required on each computer to install CopyMoveRotate.  

2.2 Licence 
Once the setup has been completed and the program is started, a licence key will be re-

quested as shown below. 

 

CAXperts will need your Current domain name to issue a licence key. 

Please place this licence key into the Licence key text box and press OK. 

 Note: Without a valid licence key the software will run in demo mode. 
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3 Working with CopyMoveRotate 
When you start CopyMoveRotate, the main window shows up: 

 

The main window is divided into three functional parts: 

▪ The control area on the left side 

▪ The project tree view on the right side and 

▪ The events log at the bottom of the window 

3.1 Privilege manager 
The Privilege manager allows you to lock functions for specific users/groups. The as-

signment of privileges is based on the Windows (domain) users and groups. This means 

that you do not have to establish a new privileges management system. 

Group and user rights are linked by an OR operation: If a group has a certain privilege 

in CopyMoveRotate, every user in this group will have this privilege, even if this privi-

lege is not explicitly stated in the settings for this user. 

The access rights are stored in an Access database (CopyMoveRotate.mdb). This is lo-

cated in the proj_file directory. The privileges are thus the same for all the projects in a 

proj_file. 
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Access to the Access database should be controlled using the Windows access rights. 

The default setting is “Allow” for every user and group. 

3.2 Settings 

 

Go to Tools→Settings to show up the Settings dialogue. 

User script file: If defined, CopyMoveRotate will execute a user defined script file 

(.bat). In this batch file, the project name is already defined in the environment variable 

PROJECT. This function may be used, e.g. if network drives containing project data 

have to be mounted or environment variables have to be set before the project can be 

accessed. In this case, PDS won‟t be started via PD_Shell but via a special software 

program that executes the commands described above. 

Label report file: if defined, CopyMoveRotate will update corresponding labels (see  

3.13 Edit piping attributes). 

Equipment models mapping file: if defined, CopyMoveRotate will preserve nozzle 

connections after copy of piping models (see 3.5 Copy models/drawings). 

MicroStation timeout: defines the time out in minutes for the Transform mod-

els/drawings command. 

3.3 Selecting a PDS project 
Go to File → Select PDS Project, this shows this dialogue window: 
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1. Select a PDS control file using the Browse button 

2. Select a PDS project from the list (double-click on it) 

Note – if you want to automatically load the last project tick the checkbox in the 

form. There is also a list of most recently used projects in the File menu which can be 

selected directly. 

3. Now, the hierarchy of the project will show up in the project tree view: 

 

3.4 Selecting objects in the tree view 
To select objects in the tree view click on the check boxes in front of the items. 
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Note – you can drop a plain ASCII file with model and drawing names (separated 

by line breaks) onto the tree view to automatically tick the check boxes of these mod-

els/drawings. Wildcards (*, ?) may be used to define the model/drawing names in the 

ASCII file. 
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3.5 Copy models/drawings 
1. Select the models/drawings or complete areas in the tree view for copying. 

2. The Export function will transfer it to Excel 

3. Edit the Excel file. There is one workbook for the models and one workbook for the 

drawings. 

 

The source structure must not be changed. The new destination structure for models and 

drawings may be configured by the user. All fields there are optional (except draw-

ing/model name), for empty fields the source value is taken. For existing areas and sub-

projects, the description will be changed according to the respective destination field. 

After saving your input file, use the Import button to start the copy process. New areas 

and framework sub-projects may also be created in this way. The models and drawings 

(including the drawing views) will be copied. 

Overwrite existing models/drawings: If this checkbox is ticked, CopyMoveRotate will 

check if there is already a model/drawing with the same name. If there is, it will be 

overwritten, i.e. the same model_index_no/partition_no/dwg_index_no will be used. 

This is reasonable if the same models/drawings are always copied automatically. With-

out this checkbox, the target models/drawings would have to be deleted and replaced 

from the original files manually. This would cause gaps in the usage of mod-

el_index_no/partion_no, the defined SiteID-range would overflow very quickly. If this 

checkbox is not ticked, copying will stop with an error message if a target file with an 

identical name exists. 

Preserve nozzle connections: if a piping model contains nozzle connection(s), they be-

come invalid after a copy (of piping and corresponding equipment models) because of 

the new partition_no for equipment model(s). To correct this and to preserve nozzle 

connections in piping models after copying, the equipment models mapping file has  

to be defined in the Tools->Settings. This file contains the mapping between source and 

destination equipment models and has exactly the same format as the Excel file for cop-

ing of Models/Drawings. Select the equipment models and click the Export button to 

create it. The destination model name must be defined and must exist before starting 

with copy of piping models. 

The workflow demonstrating how to preserve nozzle connections: 
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1. Select equipment models to copy 

2. Export selection to Excel 

3. Edit Excel file 

4. Import and copy equipment models 

5. Define the path to this Excel file from above in Tools-> Settings->Equipment models 

mapping file 

6. Now proceed with copy of piping models 

Copying of models between projects: 

▪ Export models in source project 

▪ Import models in destination project 

Note – RDB and graphical symbology must be equal. Naming conventions for 

models and drawings (according to PDS settings) must be recognised. 

Note – Import only models/drawings changed since days:  if defined CopyMov-

eRotate processes only models/drawings, which were changed within the last N days. 

The changes are recognized by using the revision_date from pdtable_113. 

3.6 Edit models/drawings 

 

All models and drawings can be renamed (and/or model/drawing description can be 

changed) through an Excel workbook. 

Note – naming conventions for models and drawings according to the PDS settings 

must be recognized. 
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3.7 Delete models/drawings 

 

All models/drawings in the Excel file will be deleted. The file may not be changed. 

Note – all files named Model.*/Drawing.* will be deleted, too 

Note –Delete models/drawings can be used interactively or using Microsoft Excel 

(for batch mode). 

Note – Import only models/drawings changed since days:  if defined CopyMov-

eRotate processes only models/drawings, which were changed within the last N days. 

The changes are recognized by using revision_date from pdtable_113. 

 

3.8 Transform models/drawings 
Before CopyMoveRotate starts a process, the participating models/drawing are saved 

in the backup directory. The directory for reporting and backups is C:\temp by default. 

1. Moving Models and Drawings 

▪ Tick all models/areas or complete project you want to move 
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▪ Input distance values for the x, y, z direction to the new location 

Note – the distance values for moving are relative, so absolute values are not need-

ed. 

▪ FrameWorks views will also be translated and rotated if the checkbox “Transform 

FrameWorks views” is checked 

▪ By pressing the Import button the models and drawings are processed consecu-

tively. 

2. Rotating Models and Drawings 

▪ For the pivot point of rotation an absolute coordinate value is needed. 
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▪ If a Design Volume Coordinate System is used in the project, the values for this 

can be added in a separate form: 

Note – drawings cannot be mirrored at this stage. The rotation of models/models is 

only possible around the elevation axis. Drawings with composite view cannot be pro-

cessed. 

By pressing the Transform selected items button the models and drawings are pro-

cessed consecutively. 

Export … to Excel generates an Excel file: 

 

You may change the rotation settings on the first tab. 

Handling for non-PDS files 
MicroStation files can also be transformed by CopyMoveRotate. 

 

Drag & Drop the directory with the MicroStation files or single .MicroStation file on 

the “Models” node of the tree view to treat the file as a model or on the “Drawings” tree 

node to treat it as a drawing. 
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Use the context menu (right mouse button) to remove non-PDS files from the tree view. 

 

Note –Move&Rotate can be used interactively or using Microsoft Excel (for batch 

mode). 

Note – Import only models/drawings changed since days:  if defined CopyMov-

eRotate processes only models/drawings, which were changed within the last N days. 

The changes are recognized by using revision_date from pdtable_113. 

3.9 Change site ID, index or partition of mod-

els/drawings 

 

For all models the site_id, model_index_no and partition_no can be changed through an 

Excel workbook. For drawings the site_id and dwg_index_no can be changed accord-

ingly. 

The user has these options: 

 Key in a new SiteID (this SiteID must already exist) 

 Key in a new model_index_no/partition_no (has to be unused) 

 Key in a new SiteID and model_index_no/partition_no (mod-

el_index_no/partition_no have to be in the range of the new SiteID) 

Correct reference files: if ticked, the logical names of reference files in all models of 

the project will be corrected, if the model_index_no of the edited model was changed. 

This can take some time if the project contains many models. If Correct reference files 

is not ticked, the logical names of the reference files won‟t be corrected. Referenced 

models won‟t be recognised as intelligent PDS models anymore, they will be displayed 

as standard MicroStation reference files. To correct this, the models have to be re-

referenced manually in PDS. 

Note –the ranges for the site_id must first be set in PDS. When changing the site_id 

as the only value, the model_index_no and the partition_no will be automatically set to 

the next free values according their PDS site_id range settings in PDS. 
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Note – Import only models/drawings changed since days:  if defined CopyMov-

eRotate processes only models/drawings, which were changed within the last N days. 

The changes are recognized by using revision_date from pdtable_113. 

3.10 Lock/unlock models/drawings 

 

Models/Drawings may be locked or unlocked. Type in the keyword locked or unlocked 

in the Lock status column. Lock owner can be a user defined string. If nothing is en-

tered the name of the current user will be used as Lock owner.  

3.11 Edit areas 

 

Area and/or description may be changed. 

Note – naming conventions for models and drawings according to the PDS settings 

must be recognized. 

3.12 Copy lines 
1. Select the lines in the tree view for copying. 

2. The Export function transfers them to Excel 



CAXperts CopyMoveRotate Reference Guide 

18 

3. Edit the Excel file.  

 

4. The source structure must not be changed. The new destination structure for lines 

may be configured by the user. All fields are optional here (except model name), for 

empty fields the source value is taken. 

Copying of lines between projects: 

▪ Export lines in source project 

▪ Import lines in destination project 

Note – there is no check against the label description library. If a LineID consists 

out of several attributes (e.g. fluid code + NPD + …) it won‟t be automatically updat-

ed; concatenated values must be updated separately. This change of database values 

should therefore only be done by experienced PDS administrators. 

Note – project version, graphical symbology settings, RDB and DDL structure must 

be equal in source and destination projects. 

Note – By default only unapproved lines will be processed. Enabling the checkbox 

Process  approved items change this behaviour. 

Note – Check for overlaps between segments: if ticked, CopyMoveRotate will 

check before copying, if line segments to copy overlap with segments of lines which 

are already in the target model (the line to copy will not be checked if it overlaps in-

ternally). The copy process will be cancelled if there is an overlap. If Check for over-

laps between segments is not ticked, lines will be copied without any checks. 

Note – Import only models/drawings changed since days:  if defined CopyMov-

eRotate processes only models/drawings, which were changed within the last N days. 

The changes are recognized by using revision_date from pdtable_113. 

3.13 Edit piping attributes 
The Design Schema for piping attributes from pdtable_12, _50, _67, _80 can be revised 

with values from an Excel Workbook. For this, first configure the attributes you want to 

export by selecting the appropriate attributes from your single pd_tables. 
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The attributes will be reported to an Excel file (Note: the report won‟t be an 1:1 image 

of the DD-Schema). If the Group rows checkbox is ticked on the entries will be 

grouped also. 

 

The different pd_table sections are in separate sheets. The attribute values can be 

adapted in the user attribute area. 

Updating labels: if any of the attributes have been changed which are part of the label,  

CopyMoveRotate can automatically update the affected labels, if label report file is de-

fined in Tools->Settings. 

Note – use PD_Shell->Reference Data->Standard Note Library->Report to create 

label report file. 

CopyMoveRotate reads the label report file and replaces the spaces by underscores in 

the all label names. If the resulting string exists as a column of pdtable_12 (DD-

Schema), the label is updated. The following standard PDS label types will be always 

updated: 

 310 - line_number_label 

 311 - line_id 
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 335 - inspections_iso_id 

Note – The user must not change attributes in the system attributes area. 

Note – The change of database values should therefore only be done by experi-

enced PDS administrators. 

Note – Updating of labels is limited to standard PDS format settings and attributes. 

For special cases and settings the attributes which are updated by using labels have to 

be edited using Excel similar to stand-alone values. 

Note – Naming conventions, attribute type and attribute length according design.ddl 

must be recognized. 

Note – By default only unapproved lines will be processed. Enabling the checkbox 

Process  approved items change this behaviour. 

Note – The Group rows checkbox, which is ticked on by default, will eliminate re-

dundant entries in the output Excel sheet. 

Note – Import only models/drawings changed since days:  if defined CopyMov-

eRotate processes only models/drawings, which were changed within the last N days. 

The changes are recognized by using revision_date from pdtable_113. 

3.14 Delete lines 

 

All lines in the Excel file will be deleted. The file may not be changed. 

Note –Delete Lines can be used interactively or using Microsoft Excel (for batch 

mode). 

Note – By default only unapproved lines will be processed. Enabling the checkbox 

Process  approved items change this behaviour. 

Note – Import only models/drawings changed since days:  if defined CopyMov-

eRotate processes only models/drawings, which were changed within the last N days. 

The changes are recognized by using revision_date from pdtable_113. 

3.15 Transform lines 
See chapter 3.8 Transform models/drawings. 

Note – By default only unapproved lines will be processed. Enabling the checkbox 

Process  approved items change this behaviour. 
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Note – Import only models/drawings changed since days:  if defined CopyMov-

eRotate processes only models/drawings, which were changed within the last N days. 

The changes are recognized by using revision_date from pdtable_113. 

3.16 Copy equipment 
1. Select the equipment in the tree view for copying. 

2. The Export function transfers them to Excel 

3. Edit the Excel file.  

 

4. The source structure must not be changed. The new destination structure for equip-

ment may be configured by the user. All fields are optional there (except model 

name), for empty fields the source value is taken. 

Copying of equipment between projects: 

▪ Export equipment in source project 

▪ Import equipment in destination project 

Note – DDL structure must be equal in source and destination models. 

Note – By default only unapproved equipment will be processed. Enabling the 

checkbox Process  approved items change this behaviour. 

Note – Import only models/drawings changed since days:  if defined CopyMov-

eRotate processes only models/drawings, which were changed within the last N days. 

The changes are recognized by using revision_date from pdtable_113. 

3.17 Edit equipment attributes 

 

The attributes of all equipment selected in the tree view are written into an Excel file, 

where you can change these values. The saved Excel file can be imported and the attrib-

utes are updated accordingly. 
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Note – naming conventions, attribute type and attribute length according eqp.ddl 

must be recognized. 

Note – By default only unapproved equipment will be processed. Enabling the 

checkbox Process  approved items change this behaviour. 

3.18 Delete equipment 

 

All equipment in the Excel file will be deleted. The file may not be changed. 

Note –Delete equipment can be used interactively or using Microsoft Excel (for 

batch mode). 

Note – By default only unapproved equipment will be processed. Enabling the 

checkbox Process  approved items change this behaviour. 

Note – Import only models/drawings changed since days:  if defined CopyMov-

eRotate processes only models/drawings, which were changed within the last N days. 

The changes are recognized by using revision_date from pdtable_113. 

3.19 Transform equipment 
See chapter 3.8 Transform models/drawings. 

Note – By default only unapproved equipment will be processed. Enabling the 

checkbox Process  approved items change this behaviour. 

Note – Import only models/drawings changed since days:  if defined CopyMov-

eRotate processes only models/drawings, which were changed within the last N days. 

The changes are recognized by using revision_date from pdtable_113. 

3.20 Edit nozzle attributes 
See chapter 3.17 Edit equipment attributes. 
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3.21 Edit raceway attributes 

 

The attributes of all raceway models selected in the tree view are written into an Excel 

file, where you can change these values. The saved Excel file can be imported and the 

attributes are updated accordingly. 

Note – naming conventions, attribute type and attribute length must be recognized. 

Note – Import only models/drawings changed since days:  if defined CopyMov-

eRotate processes only models/drawings, which were changed within the last N days. 

The changes are recognized by using revision_date from pdtable_113. 

3.22 Edit reference files 

 

The user may change reference files of models/drawings with this function. If 

CopyMoveRotate finds the new reference file in pdtable_113 of the current project 

schema, it will automatically retrieve the logical name and description file and attach 

the reference file as an intelligent PDS model. 

If the user changes the drawing border file, logical name and description of the new ref-

erence file will stay constant – “BORDER”, “DRAWING BORDER FILE”. 

The source reference file will be replaced in all drawing views. 

 

3.23 Command line mode 
CopyMoveRotate also works in command line mode. If you click on Tools → Create 

batch file, a demonstration batch file will be generated. 

copymoverotate /? shows the available command line parameters: 

------------------------------------------------------------ 
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           CAXperts CopyMoveRotate 

------------------------------------------------------------ 

 

 

Command line arguments for CopyMoveRotate.exe: 

 

/CMD control_file.cmd    - Path to the control file. 

                           If control file is not defined, last 

                           control file will be used. 

 

/Project project_name    - PDS-Project name. 

                           If project name is not defined, last 

                           project will be used. 

 

/Mode mode               - Execution modes: 

                           MODEL_COPY - copy models/drawings 

                           MODEL_EDIT - edit models/drawings 

                           MODEL_DELETE - delete models/drawings 

                           MODEL_TRANSFORM - transform mod-

els/drawings 

                           CHANGE_SITE_ID - change 

SiteID/Index/Partition 

                                            of models/drawings 

                           CHANGE_LOCK_STATUS - lock/unlock mod-

els/drawings 

                           AREA_EDIT - edit areas 

                           DD_EDIT - edit piping attributes 

                           LINE_COPY - copy lines 

                           LINE_DELETE - delete lines 

                           LINE_TRANSFORM - transform lines 

                           EQP_COPY - copy equipment 

                           EQP_EDIT - edit equipment attributes 

                           EQP_DELETE - delete equipment 

                           EQP_TRANSFORM - transform equipment 

                           EE_EDIT - edit raceway attributes 

                           REF_EDIT - edit reference files of mod-

els/drawings 

 

/XLS excel_file.xls      - Path to the Excel file to process 

 

/Config config_file.ini  - Config file. 

                           If not defined, last 

config file will be used. 

 

/export                  - If defined excel file 

                           will be created for defined execution 

mode 

 

/batch                   - If defined CopyMoveRotate 

                           will be run in batch mode 

 

Example: 

 

CopyMoveRotate.exe /CMD control_file.cmd /Project project_name /Mode 

MODEL_COPY 

/XLS excel_file.xls /batch 
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3.24 Colour mark-up in reports 
Most CopyMoveRotate processes are reported into Excel workbooks. For every pro-

cessed model/drawing the status is indicated in three possible colours: 

▪ Status: OK; colour: green: the model/drawing passed the process without any er-

ror. 

▪ Status: warning; colour: yellow: while processing the model/drawing some prob-

lems occurred, which are reported in the next field „description‟. These warning 

messages should be checked in the appropriate models. 

▪ Status: error; Colour: red: the process for the model/drawing failed. The reason for 

this is described in the „description‟ field 
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4 Technical support 
Need more help? Contact CAXperts support by email, online, or phone: 

mailto:support@caxperts.com 

http://www.caxperts.com/component/option,com_contact  

 

 

mailto:support@caxperts.com
http://www.caxperts.com/component/option,com_contact
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